Problem description
On macOS devices, restoring data through inSync client fails with disk I/O error.
Restoring data from server to Client (Original location, Desktop, Custom location ) also gets stuck and fails with disk I/O error.
Cause
Some of the possible causes for this error are as follows:
Antivirus scanning enabled for Druva folders on the device.
Low disk space on the system drive.
Read and write getting impacted due to very high disk utilization on the device.
Some other 3rd party applications have a handle on inSync Client.
inSync Client database files have gone corrupt.
Traceback
inSyncClient.log:
{code}
[2020-04-14 16:42:41,322] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
[2020-04-14 16:42:41,323] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
[2020-04-14 16:42:41,323] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
[2020-04-14 16:42:41,323] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
[2020-04-14 16:42:41,323] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
[2020-04-14 16:42:41,324] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
{code}
Resolution
Do the following steps to identify the possible causes and resolve the issue to avoid further occurrence of the restore error:
Stop Druva services on the affected device and enable debug logging on the client machine.
When the error reoccurs, check the file for which the error has occurred. The logs will be available at the following locations:
The client logs from ~/Library/Application Support/inSync/logs directory.
The inSync.cfg from ~/Library/Application Support/inSync directory.
There could be a handle on the restorestate.db file in restorestate folder present in the location: ~/Library/Application Support/inSync/restorestate.Do the following steps for resolution:
Stop Druva inSync client service
Rename restorestate folder to restorestate.old
Launch inSync Client again.
The restore should work fine if there is any corruption or issue related to restoring the database file.
If the issue still persists, uninstall the inSync Client and install the inSync Client again. Perform a restore operation and check the behavior. With this resolution, new database files are created without any handle or corruption.
In case of any machine-specific issues, refer the following logs for further analysis and troubleshooting:
System Log Folder: /var/log
System Log: /var/log/system.log
Mac Analytics Data: /var/log/DiagnosticMessages
System Application Logs: /Library/Logs
Console logs
If the error continues to occur, contact Druva Technical Support for any further assistance or help.
Verification
Restoring data from inSync Client and server should start working as expected.