Skip to main content
Endpoint Client backup with encryption enabled fails
Updated over 11 months ago

Problem description

inSync Endpoint Client backup with encryption enabled fails to complete

Cause

Windows EFS Recovery certificate may have expired or not available on the machine due to some reason like machine re-image.


๐Ÿ“ Note
โ€‹Druva inSync uses Encryption File System (EFS), a feature of Windows, to encrypt and decrypt data on your Windows laptops and desktopsDruva inSync does not backup the EFS keys used for encryption by Windows.Druva inSync does not backup data in encrypted format from Windows laptops and desktops.. Data is decrypted in plain text format and then backed up.


Traceback

[2021-07-08 10:00:09,180] [ERROR] Encrypting: \\?\C:\Users\1364\Desktop\gratutiy letter.doc Got Error: (6012, 'EncryptFile', 'Recovery policy configured for this system contains invalid recovery certificate.')

Resolution

Either renew the existing certificates or generate new certificates for the EFS recovery agents and reapply the recovery agent policy with those certificates.

See also

Did this answer your question?