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AMI backups fail with instance does not have a volume attached at root error
AMI backups fail with instance does not have a volume attached at root error
Updated over a week ago

Problem description

AMI backup task fails with the below error for an instance:

CRAMIBackupError.png

Cause

AMI was not created due to one of the following reasons:

  • The root device was detached from the instance.

  • The root volume was deleted and hence was not detected.

CRAMIBackupErrorCause.png

Resolution

Recover the root volume from a previous CloudRanger backup:

  1. Select the required snapshot and choose to restore as a volume. Ensure the availability zone selected is the same as the instance.

    CRRestoreSnapshot.png


    The newly created volume will show up under the restores section.

    CRRestores.png
  2. Find the root volume in AWS console and select Attach Volume.

    CRCreateVolume.png
  3. Select the correct instance and specify the block device mapping as /dev/sda1 and click Attach.

    CRAttachVolume.png

Backups should now run without any issue.


💡 Tip

If you find the detached volume without restoring you can just attach it to the correct instance to fix the issue.


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