Skip to main content

VMWare FLR | Failed to browse the Guest VM Directory

VMWare FLR | Failed to browse the Guest VM Directory.

Updated this week

Problem description

When attempting to browse a guest VM directory for VMWare FLR on a VM, the following error appears:

Failed to browse the guest vm. Error: Failed to establish connection with vCenter/ESXi [open /tmp/x.pem: no such file or directory]

Cause

  • The process requires an SSL certificate (.pem file) to authenticate with vCenter/ESXi.

  • The file x.pem is missing, deleted, or stored in a non-persistent location (/tmp/), which may be cleared after a reboot.

  • Misconfigured path or permission issues prevent the system from locating/using the certificate.

Traceback

Failed to browse the guest vm. Error: Failed to establish connection with vCenter/ESXi [open /tmp/x.pem: no such file or directory]

Resolution

Verify the Certificate File:

  • Verify if x.pem exists in /tmp/.

  • If missing, re-import a new certificate from vCenter/ESXi using “ProxyConf” utility.

  • Use option : Provide vCenter/ESXi FQDN (or IP address) and credentials to import new .pem file

  • Restart Backup Proxy Service.
    service Druva-EnterpriseWorkloads restart

    Note: The file path and certificate file name, such as /tmp/x.pem, may vary depending on your configuration.

Disable the secure communication: [Workaround]

  • Disable the secure connection as the .pem file is not accessible at the destination.

  • Login to VMWare backup Proxy.

  • Check the secure connection flags
    grep cc_ssl_insecure etc/Druva/EnterpriseWorkloads/vmware/VMwareConfig.yaml
    Note: If Output is “false”, Secure communication is enabled.

  • Backup Current Config file:
    cp /etc/Druva/EnterpriseWorkloads/vmware/VMwareConfig.yaml /etc/Druva/EnterpriseWorkloads/vmware/VMwareConfig.yaml.old

  • Set the flag from False to true.
    sed -i 's/cc_ssl_insecure: false/cc_ssl_insecure: true/' /etc/Druva/EnterpriseWorkloads/vmware/VMwareConfig.yaml && systemctl restart Druva-EnterpriseWorkloads

  • Verify the change:
    grep cc_ssl_insecure /etc/Druva/EnterpriseWorkloads/vmware/VMwareConfig.yaml

Note: Output should be “true”


Verification

  • Perform the FLR Restore.

See also

Did this answer your question?