Skip to main content

Error creating a backupset for Managed Instance – Failed to get subnet details.

Error creating a backupset for Managed Instance – Failed to get subnet details.

Updated over a week ago

Problem description

This document helps customers on how to resolve when they faced the issue while creating a backupset for Managed SQL Instance.

Cause

The absence of a subnet named “default” subnet to spawn the Druva's Quantum Bridge in Vnet where Managed instance is deployed.

Traceback

Failed to get subnet details: GET https://management.azure.com/subscriptions/27d73645-****-****-ba9c-4258*****/resourceGroups/Support/providers/Microsoft.Network/virtualNetworks/vnet-mitestpoc/subnets/default --------------------------------------------------------------------------------

RESPONSE 404: 404 Not Found ERROR CODE: NotFound --------------------------------------------------------------------------------

{ "error": { "code": "NotFound", "message": "Resource /subscriptions/27d73645-****-****-ba9c-4258*****/resourceGroups/Support/providers/Microsoft.Network/virtualNetworks/vnet-mitestpoc/subnets/default not found.", "details": [] } } -----------------------------------------------------------

Resolution

  1. Login to the Azure subscription.

  2. Go to Virtual Networks.

  3. Select the Network that is assigned for Managed Instance.

  4. Go to subnet Sections.

  5. Create a “default” Subnet

  6. Once the default subnet is created, you should be able to create a subnet successfully.

Note: The subnet attached to the managed instance is delegated and hence can't be used for Druva's Quantum Bridge.

Did this answer your question?