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Enterprise Workload Agent Activation Failure (x509: certificate signed by unknown authority)
Enterprise Workload Agent Activation Failure (x509: certificate signed by unknown authority)

Enterprise Workload Agent Activation Failure (x509: certificate signed by unknown authority)

Updated over 2 weeks ago

Problem description

The Enterprise Workload Agent activation failed with the following error message:

Traceback

Failed to activate. Resource not found Error in discovering URLS. Error in discovering service PhoenixSyncServer using activation token: Post "https://phoenix-globalapis.druva.com : 443/directorysvc/v1/ services/ PhoenixSyncServer/deviceToken" : x509: certificate signed by unknown authority

Cause

The firewall changes the certificate's Canonical Name (CN) field, resulting in certificate validation failure.

In this screenshot, we can see that the CN field is changed by the firewall

Resolution

  1. To troubleshoot this issue run the following command on the machine:
    โ€‹openssl.exe s_client -connect phoenix.druva.com:443 -brief

  2. Validate the output results.

  3. Add *.druva.com to the exclusion list in SSL inspection of firewall list to prevent the certificate validation issue. Refer Firewall, Antivirus and Network Configuration for Druva Enterprise Workloads | Druva | Documentation

  4. After adding the exclusion in the SSL inspection in the firewall following are the results:

  5. Rerun the activation using the activation token.

See also

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