Backups do not work on iOS devices
Updated over a week ago

πŸ“ Note
​This article applies to

  • OS: iOS

  • Product edition: inSync Client on iOS mobile devices


Problem description


Scheduled and manual backups on iOS devices fail to complete if inSync App goes to background.

Cause

  • The ongoing backup task is continued in a background thread when inSync App goes into the background on iOS devices.

  • iOS allows inSync App to run for 180 seconds in the background thread. After 180 seconds, iOS kills the application forcefully.

  • This is a the default behavior of iOS and there is no workaround to restart the backup until inSync App is brought to the foreground.

Resolution

Enable device trace, so that:

  • The inSync App on your device gets registered for "Significant-change-location".

  • Device trace will trigger when the device location changes significantly and will wake up the inSync App for the next 180 seconds.

  • With the callback, inSync App checks if it is time to back up and tries to connect with inSync Server to trigger a backup.


πŸ“ Note
​Disclaimer

  • The term "Significant" is not explicit in "Significant-change-location". iOS determines this at runtime.

  • Callback may never come to the app if the device has not moved.


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