Skip to main content

Backup/Restore Failure – Error While Connecting to IOServer Process [Failed to Establish Session with GRPC Server]

Backup/Restore Failure – Error While Connecting to IOServer Process [Failed to Establish Session with GRPC Server]

Updated today

Problem description

The backup/restore job fails with the error: "Error while connecting or disconnecting to IOServer process [Failed to establish session with GRPC Server]"

Cause

This issue occurs during the backup/restore workflow when the druva service attempts to connect to the local IOServer process over RPC on port 20000. The problem can be reproduced in environments where there are hostname resolution issues on the database server.

Traceback

Oracle.log

<level=error ts=2025-05-24T05:31:46.673822098Z filename=restore.go:740 Message="Failed to establish session with GRPC Server" Error="Session Start failed: rpc error: code = Unavailable desc = connection error: desc = \"transport: Error while dialing: dial tcp [::1]:20000: connect: connection refused\">

Resolution

  1. Log in to the database server.

  2. Edit the /etc/hosts file through VI

    • Map the server’s hostname to its IP address ( example: 10.10.2.1)
      10.10.2.1 <hostname>

  3. Save the file.

  4. Reinitiate the backup/Restore.

Did this answer your question?